Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now

Posted on: Nov 26 2008, 06:54 PM

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 26-November 08
Member No.: 13,768

Hi guys -

After adding a new IP address in


and updating vhost,
when restarting the service

#service network restart

Everything is returned OK, except for the aforementioned flag:

#SIOCADDRT: File exists

Which I believe is restricting the IP address from working correctly; the web folder is only accessible via the IP address and not the domain name resolved to it...

As this is a duplicate error message what can be done about resolving it?
There are a fair few other IP addys working perfectly on the same network.

I've tried removing the IP from ifcfg and vhosts then rebooting, but still no joy any help much appreciated.

All Device lines are written respectively to the ifcfg they are in.

1. vi /etc/sysconfig/network-scripts/ifcfg-eth0:7
2. route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 eth0 U 0 0 0 eth0 UG 0 0 0 eth0
3. netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface * U 0 0 0 eth0 * U 0 0 0 eth0
default server192-176-2 UG 0 0 0 eth0


Are there any other files that I need to be looking at to fix this, other than vhost.conf?

I'm almost certain
#SIOCADDRT: File exists
is to blame, but how to fix!?
  Forum: Technical Support · Post Preview: #30718 · Replies: 1 · Views: 6,055

New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic

RSS Lo-Fi Version Time is now: 26th May 2018 - 11:00 AM