Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now

YunHarla
Posted on: Jun 7 2004, 10:50 PM


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 26-May 04
Member No.: 3,040


Ah ha. finally fixed it. Got to append some drv mapping cmd to the grub cmd:

#for WinXP boot entry in grub.conf
rootnoverify... #forgot exact thingy liao
chainloader +1
map (hd0) (hd1)
map (hd1) (hd0)

probably cos the WinXP needs to boot from its own drive instead of from Linux drv as set in Bios.
So, grub is compatible with SATA provided the bios settings are correct (wish MSI had provide more details on the ide/sata config)

---
checked out fdisk -l too (or maybe sfdisk), and it complained that 1 of the drv partition table is not quite right-something abt mismatched CHS---but anyway since Linux is working, I'm going to ignore it wink.gif

---
Lastly, a Big Thank You to lesio for your kind advice and assistance smile.gif
  Forum: Technical Support · Post Preview: #13915 · Replies: 7 · Views: 4,109

YunHarla
Posted on: Jun 2 2004, 07:56 PM


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 26-May 04
Member No.: 3,040


Sadly after trying several combinations of (hdx,y), none worked. Tried going into grub command line mode, and found that grub couldn't access one of the drive:

grub>geometry (hd1)
Disk read error

Seems that grub can't read the hdd with WinXP correctly. Any suggestions on how to remedy that...I don't seem to have any problems in WinXP so it's weird grub can't access the hdd when xp can.

Thanks.
  Forum: Technical Support · Post Preview: #13740 · Replies: 7 · Views: 4,109

YunHarla
Posted on: May 30 2004, 09:00 PM


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 26-May 04
Member No.: 3,040


Thanks lesio1974.

After randomly changing the SATA/IDE config, i hit on a working config: Previously my SATA hdd was primary master, IDE hdd was tertiary master, and the IRQ problem cropped out. Now, with the IDE hdd as primary master, Sata hdd as 3rd master, FC2 could be installed.

Now a different problem came up:
On rebooting, the grub boot loader never showed up, and pc went right into WinXP. (System config: WinXP in Sata hdd, FC2 in IDE hdd. Bios set to boot from Sata hdd).

I tried changing setting in bios to boot from Ide hdd. Now, grub shows up and can go into FC2. However, if I chose WinXP, WinXP couldn't start.

How to fix this? Any help is appreciated. Thx.
  Forum: Technical Support · Post Preview: #13608 · Replies: 7 · Views: 4,109

YunHarla
Posted on: May 26 2004, 08:56 PM


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 26-May 04
Member No.: 3,040


Hi, was trying to install Fedora Core 2 but when the installer is starting up: it keeps looping and throwing out this error:

Disabling IRQ #10

After sometime, it goes to either the load driver or check media screen, but then "Disabling IRQ #10" will keep popping up again with some garbage characters.

Anyone knows how to resolve this? Thanks ",

System spec:
P4 2.8c GHz 1GB RAM
MSI 875P Neo-FISR2
Seagate 160GB SATA HDD
IBM 120GB IDE HDD
Samsung DVD/CDRW Combo
  Forum: Technical Support · Post Preview: #13451 · Replies: 7 · Views: 4,109


New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 

RSS Lo-Fi Version Time is now: 20th October 2017 - 02:03 AM