Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Issues with RSync

Posted by: Eambo Jul 12 2011, 05:51 PM

Hi Everyone,

Sorry if this is the wrong place to put this, I'm quite the Linux noob. Basically I'm using the following:

CentOS Linux server
Windows 7 home computer

I'm trying to use DeltaCopy Client (RSync wrapper for Windows) to sync a file up to my server. RSync is running on my server as root, and I have made sure I chown the folder I'm uploading to, and I can create directories/files no problem on that account. However I'm getting this error with RSync:

Executing: rsync.exe -v -rlt -z --chmod=a=rw,Da+x --delete "/cygdrive/C/TestFile" "<User>@<Server>::upload/TestFile"

building file list ...


rsync: mkstemp "/.TestFile.CtM2Er" (in upload) failed: Permission denied (13)

sent 40381 bytes received 38 bytes 11548.29 bytes/sec
total size is 90112 speedup is 2.23
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/main.c(1040) [sender=3.0.4]

Partial transfer due to error
Rsync.exe returned an error. Will try again. This is retry number 2 of 5

The "upload" is the virtual directory I'm using.

My RSyncd.conf is as follows:

motd file = /etc/rsyncd.motd
log file = /var/log/rsyncd.log
pid file = /var/run/
lock file = /var/run/rsync.lock

path = /var/www/html/Files
comment = Comment!
uid = nobody
gid = nobody
read only = no
list = yes
auth users = <User>
secrets file = /etc/rsyncd.scrt

Does anyone have any idea what I'm doing wrong? Thanks!

Posted by: Eambo Jul 12 2011, 10:04 PM

Sorry for the double post - got a little bit further.

I can now add files it seems (I've only tried small ones). However the main reason I wanted to use RSync was to update a .rar file I have on the server, without needing to upload the whole folder.

Now what happens when I try to do this is it gets to "Building file list ...." then goes through what I assume is a verification/validation (1 file to consider?). When it's finished, I get this:

1621201280 325.41kB/s 1:21:05 (xfer1, to-check=0/1)
rsync: mkstemp "/File.rar.bc6hkx" (in upload) failed: Permission denied (13)

So somewhat forward, but still at step one :-P

For anyone interested, I had to use filezilla and changed my folder permissions to 744 again - it was already 744 but for some reason doing it via filezilla allowed me to continue...

Posted by: Eambo Jul 14 2011, 06:14 AM

The issue seems to be resolved. It was one of two things causing it:

1 - Having the .rar file I was uploading open. Not sure if I was doing this originally but definitely was the cause second time (derp me!)

2 - Having to change permissions from 744 to 755. Not sure if it was a combination, I done both of these things and it worked. Hopefully this will help someone in thefuture with their issues.

Posted by: michaelk Jul 14 2011, 03:56 PM

Thanks for posting back that you found the solution.

Powered by Invision Power Board (
© Invision Power Services (