Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Clueless newbie needs help

Posted by: cazo Apr 8 2009, 01:33 PM

I was given a second hand CnM Minibook (no instructions) with a Linux OS. I've never used Linux before, but had no problem with Xip Word or Xip Table etc. Trying to familiarise myself with the system, I downloaded some free games, but cannot use them. The files appear, but when I try to open them nothing happens. The file extensions are .tgz. I've searched this forum and others and they all seem to say that you need to type various commands in a terminal - I've no idea what this means - I've been unable to find anywhere to type any kind of command, or anywhere to login as root user. I don't have to login when I switch on - it goes straight to the equivalent of windows desktop.

Am I being completely dense?

Any help appreciated - even if it's to tell me I'm stupid!

Posted by: michaelk Apr 8 2009, 04:41 PM

I am unfamiliar with this netbook but I believe it runs debian or ubuntu which is based on debian.
In the olden days of main frames before GUIs existed computers were accessed from a terminal (DEC VT220 was a popular model) which was basically a monitor and keyboard. A terminal application (such as xterm) emulates a terminal where by you can type in commands. From the task bar select Applications -> Accessories -> Terminal. There also could be an icon on the task bar that looks like a monitor. Furthermore if you shutdown
the x server i.e. no GUI running there are 6 virtual terminal consoles that can be assessed vi the Alt F1-F6 functions keys.

tgz is a compressed tar file. To uncompress use the following command
tar -zxvf file.tgz

Normally tgz files are the source code and need to be compiled in order to execute. There should be a read me file of some type which includes instructions on how to compile.
A tgz file could also mean a slackware package. A package is all the files compiled for a particular distribution. Basically a package has all the installation bugs worked out for you.

With Ubuntu if you need run a command with root privileges you use sudo i.e.
sudo ifconfig

However, it is possible to setup a root password if desired.

There is a bit of a learning curve but you will find that linux can be more powerful then windows.

Posted by: cazo Apr 9 2009, 12:42 PM

You're certainly right about the learning curve - I consider myself a fairly competent windows user, but Linux makes me feel like a total idiot. The only icon on the task bar is the one which lets you view which programs are running - there is no "applications" or "accessories". Someone told me that it may be possible to access a terminal by holding down Ctrl+Alt+T, but this doesn't work either. I'm afraid you lost me on GUIs and x server - I don't know what they mean. I haven't even been able to identify which version of Linux I've got.

I don't know if this will help, but when I switch on, this is what I get:-
Main screen has five buttons across the top - Internet; Work; Play; Settings; Others.
On selecting a button you get a choice of icons within that group.
Internet = Web Browser, Email box, Xip chatting, FBReader, Network dial up, WiFi, Mobile connection.
Work = Xip word, Xip table, PDF reader, Dictionary, Calendar, Calculator, File manager.
Play= Media player, Xip flash player, Image gallery, Paint brush.
Settings = Desktop template, Sound setup, Date/Time setup, Network setup, Owners profile.
Others = Xip tar, Software installer, Recorders.

I thought that Xip tar or software installer would allow me to unzip/install files, but no such luck. I have no idea what to do next, or even whether it's worth persevering.

Any suggestions gratefully received

Posted by: michaelk Apr 9 2009, 04:49 PM

Does not help. You can try pressing the CTRL-DEL- Backspace keys to see if that kills the GUI.

Posted by: cazo Apr 10 2009, 03:36 AM

Thanks Michael - tried this but it didn't work. (I have now found out what a GUI is, so at least I've learnt something!).

In desperation, I've even tried various combinations of CTRL+ALT+Function in the hope I might stumble across the secret code - no joy.

I'd heard that Linux was so much better than Windows, but if I can't do something as simple as download and install Solitaire, I'm losing faith.

I'm approaching the point where I think a hammer is the only solution- (either that or have Windows installed). Aaargh!!!!

Powered by Invision Power Board (
© Invision Power Services (