Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ mpiexec help

Posted by: DarienFox Feb 11 2009, 07:22 PM

Hi all,

I am submitting parallel jobs like so:

mpiexec -np 12 -machinefile < nodes.inp ./myprogram

The nodes.inp file contains the list of nodes to be used. But the mpiexec thinks the ./myprogram is also a file to be read by -machinefile so mpiexec tells me that I haven't given it an executable but indeed "myprograms" is an executable. How can I tell linux to only input just one file to -machinefile (or any linux program for that matter, doesnt have to be mpiexec), obviously "<" is not working. Any suggestions could be awesome! Thanks!

Posted by: michaelk Feb 11 2009, 08:34 PM

mpiexec -np 12 -machinefile < nodes.inp ./myprogram


After looking at the man pages for mpiexec I do not see a reason to use <. Have you tried.
mpiexec -np 12 -machinefile nodes.inp myprogram

Posted by: DarienFox Feb 11 2009, 10:14 PM

Thanks a lot, MichaelK.

I had indeed tried that but I get another error, part of which is:

mpiexec: spawn failed with errno=-11

I googled this and it seems I should get rid of the -machinefile part of my mpiexec command. That works, problem is the code is designed to submit executables on these nodes again and again before the job is suppose to terminate. Those executables must know which nodes I have reserved for them to run so I have to use the -machinefile option (unless someone knows a better way to do this). So if I get rid of the -machinefile part the first part of the code works but once a further executable is submitted, it doesn't know the nodes to submit to and terminates. Any thoughts? Thanks again!

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)