Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Linux Server - Can't get FTP site to work - IP Address Issue?

Posted by: SSP Dec 10 2008, 06:28 PM

Okay, I don't know really anything about Linux but my old tech person, who I can't seem to find, set us up with Linux on our server. I have a FTP site that I was told is ran by Apache on our server. I have an account at DNSExit for the address My customers started complaining that they can't get to my FTP site. I also can't connect remotely to my PC at work now. In the past this has been an issue with an IP address changing according to my old tech. I have some notes to see if the Apache service is running and it is. I am presuming it is again an IP address issue but I don't know where to start. I checked my IP address on the server and it starts with a 192 number. The IP address in my DNSExit account shows a completely different number starting with a 67. I know this is due to the fact that I have a Linksys router but have no idea how to find the actual IP address [not the router 192 number] on the server. Does this sound like something someone can help direct me in a quick fashion?

Thank you for your help

Posted by: SSP Dec 10 2008, 07:03 PM

By the way I have checked my router and I have it configured to forward port 80 to the IP address of the webserver [the 192 number]. When my tech person left I made screen prints of all my router pages so I know nothing has changed in any of those settings. The only thing I changed on the router was the RDC IP address to match my PC at work so I can hopefully remotely log in when I get home tonight. Not sure if this is what will do it but I'm giving it a shot. Any help is greatly appreciated. Remember, consider me 'directionally challenged' so the more detailed of where to find the things I need and how to get to them on your responses the better [i.e. go to Applications - System Tools .... etc...]. Thanks everyone.

Posted by: michaelk Dec 10 2008, 08:36 PM

Your sever is on a local LAN with a private IP address of 192.168.x.x. Your ISP provides a dynamic IP address which is the 67.x.x.x number. This 67 number is the WAN IP address of the router.
DNSexit basically provides a DNS service which always points your URL i.e. to your public IP address. There probably is a program that runs on the server which will update DNSexit
at a set interval with your WAN IP address.

Then when someone types in your URL i.e it will automatically point to your WAN IP address i.e 67.x.x.x. the router will then forward the request to your server. The quickest method to find your WAN ip address is type in in your browser from the server. The address that is now associated with is I found this out by using the ping command in a console window. If this address does not match what is displayed by then your client program may not be running. I am not familiar with DNSexit so I do not know anything about its client program.

I asume that everything still works on your local network. I do not know what you mean by RDC IP address but it would be best to go back to the original configuration. Once you know your public
IP address you should be able to enter it into the browser on an outside computer and see your site. You will also need to provide some additional details on how you connect remotely to your PC
at work.

Without knowing the linux distribution / version it will be difficult to provide exact "directions".

Posted by: SSP Dec 11 2008, 08:41 AM

Hi Michael. I have gone to "" from the Linux server and it comes up with Would it be that different from the number you provided earlier? That seems strange to me as I would think it would follow the 67.52.236. and only the last digits would change. When I check my router that is what it shows as my Internet IP Address.

Yes, everything still works on the local network. I changed the RDC IP address back to the original configuration. The took me to my router when I typed it into the web browser.

I'll check on the DNSexit client to see if I have it or if it is running. Where would I find the client on the server [I went to Add/Remove programs to see if it was listed and I didn't see anything for DNSexit client but I'm not sure that is where I should be looking]. The only thing I saw with any type of DNS in the name was "DNS Name Server" under the "servers" category and it was not checked. I'm am presuming this will allow me to use a name instead of an IP address and it would point to the name of the server so it wouldn't rely on having to find the IP address - but again I'm guessing.

I connect from home using the Remote Desktop Connection. My tech had made a file called 123ssp.RDP. I just double click on it and it prompts me for a username and password. It gets to that point at home now but when I type in the username and password they do not work. I have not changed my username and password so I know they are still good since I use those to connect to my router all the time [just a minute ago when checking the Internet IP address]. It connects me directly to my PC at the office so it is as if I'm working right at work.

I'm not sure how to check my version of Linux. I did a Google search and found that I could run uname -a and it came up with the following:
Linux localhost.localdomain 2.6.9-42.0.3.ELsmp #1 SMP Fri Oct 6 06:21:39 CDT 2006 i686 i686 i386 GNU/Linux

Is that what you needed? Do you know another command I can use? I tried cat/etc -release and "cat/etc" -release, which was another suggestion and it wouldn't work.


Posted by: SSP Dec 11 2008, 09:06 AM

A couple more things. I changed the IP address at to the and it just directed me to my router username and password when I went to I changed it back to the The way it normally worked was when someone went to it would take them to a login screen and they would type in the username and password in order to upload files. It would take them to the upload screen. When someone uploaded a file, it automatically went to a folder on my file server called "uploads". I would just go to that file on my file server to get those uploads. When I go to my uploads folder the path is "Newtwork-". I see this IP address in my router under the Port Forwarding for webmin, ssh, FTP and WEB. Does this help with other ideas? There has to be a way that I can find where the is pointing and run some sort of command to check that IP address and see if that has changed but I'm not sure how since the "" only directs me to my router instead of the upload screen and upload files into my file server folder like it should.

I also Went to and it had the following:

Tips for the Linux script:

* To start the program automatically after reboot. You need to run command
>> chkconfig ipUpdate on ( for linux distribution including Fedora/RHEL/CentOS)
>> insserv ipUpdate ( for Suse linux)
* File "/tmp/dnsexit-ip.txt" will cache the ip address of the last successful IP update to our system. For next update, if the IP stays the same, the update request won't be sent to our server. You can simply change the IP at dnsexit-ip.txt file to force the update to DNSEXIT.
* File "/var/log/dnsexit.log" contains the update history for your IP.

I see that CentOS is on my server so I used that command and it did not recognize it at all. I was in the sbin directory when I tried it.

Posted by: SSP Dec 11 2008, 09:38 AM

I GOT IT! It was simple after all. I don't know about connecting from home yet, but I do know that my customers can now get to the FTP site log in screen and do their uploads. This was an issue where the router IP address changed.

Here is exactly what fixed the issue:
Go to web browser and get to router
Go to the "Applications & Gaming" - "Port Range Forwarding" section. Make sure ALL items have a checkmark under "Enabled". Save changes.
Go to the "Status" "Router" section. Write down the new Internet IP Address. [or you could get on the server and go to to get the new IP address]
Go to
Go to the "My Account" at the top of the page and log in
Find the "Domain List" section and click on "Edit DNS"
Under the "Host Records" click on "edit"
Type in new IP Address that from the router Internet IP Address. Click on "Update Host" button. Click on "Save" at the top.


Thank you for helping me find my way Michael.


Posted by: michaelk Dec 11 2008, 09:40 AM

If you are trying this from your internal network then you might see your router login page vs the server's web page. This is normal.
If I use your IP address i.e. in my webbrowser I get a login page. Web page title is SSP Upload Location.
If I try the 67.x.x.x address I get a communication error.

So I think my initial assumptions were correct.

I guess I posted this a little late....

Posted by: michaelk Dec 11 2008, 09:48 AM

So I assume that the ipudate program is not running.
Typically a regular users path does not include sbin. linux is different from windows such that the path environment does not include the current working directory.
So even though you were in sbin you could can not run an application unless you use the full path or the shortcut ./

Powered by Invision Power Board (
© Invision Power Services (