Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ #SIOCADDRT: File exists

Posted by: 1080p Nov 26 2008, 06:54 PM

Hi guys -

After adding a new IP address in

#/etc/sysconfig/network-scripts/ifcfg-eth0:7

and updating vhost,
when restarting the service

#service network restart

Everything is returned OK, except for the aforementioned flag:

#SIOCADDRT: File exists

Which I believe is restricting the IP address from working correctly; the web folder is only accessible via the IP address and not the domain name resolved to it...

As this is a duplicate error message what can be done about resolving it?
There are a fair few other IP addys working perfectly on the same network.

I've tried removing the IP from ifcfg and vhosts then rebooting, but still no joy any help much appreciated.

All Device lines are written respectively to the ifcfg they are in.

1. vi /etc/sysconfig/network-scripts/ifcfg-eth0:7
====================================
DEVICE=eth0:7
BOOTPROTO=static
IPADDR=192.176.240.190
NETMASK=255.255.252.0
BROADCAST=217.174.243.255
NETWORK=217.174.240.0
ONBOOT=yes
TYPE=Ethernet
2. route -n
========
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.176.240.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.176.240.1 0.0.0.0 UG 0 0 0 eth0
3. netstat -r
=========
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.176.240.0 * 255.255.252.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default server192-176-2 0.0.0.0 UG 0 0 0 eth0

=========================================================

Are there any other files that I need to be looking at to fix this, other than vhost.conf?

I'm almost certain
#SIOCADDRT: File exists
is to blame, but how to fix!?

Posted by: michaelk Nov 30 2008, 02:31 PM

At first glance it appears you are trying to add a host route with the same IP address.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)