Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Console

Posted by: lol Mar 19 2008, 03:21 PM

Hi all,

I am Very New to Linux.
I have Ubuntu linux thing.. installed with wubi.
I have Dual-boot. ( Windows. or Linux ) ( now windows T_T )
I have NO internet on Linux, because I cannot install my driver.

The problem:

- I have to install some .tar.gz files, with the CONSOLE ( I have admin pass).
But I have no idea where the '' console'' ever might be. ( This is probally the funniest thing you al hear tongue.gif ).
And if I find the console, what must I type in for install the .tar.gz files ?

Posted by: michaelk Mar 19 2008, 09:13 PM

Depends on the desktop but typically there is an icon on the tool bar that looks a computer monitor. Clicking this icon will pop up a window where you can type commands.
There are several x window console applications but it is probably running xterm.

tar.gz are usually source files that must be compiled and then installed which is copying the necessary executable / configuration files to the desired destination directories. tar.gz files are similar to windows zip files and must be extracted first.

tar -zxvf filename.tar.gz

Once the files have been extracted look in the extracted directory and you should find some kind of readme file that explains how to compile and install the application.
BTW tar is a file archiver which basically combines many files into one, gzip is a utility that compresses files. So this is where the tar.gz extension comes from.

What ethernet adapter are you trying to get working?

Posted by: lol Mar 20 2008, 01:38 AM

Thanx for ansering

Using ubuntu...
I am trying to configure :
Sitecom wl 151.

Still can't find the Console - .- '' . I am probally so lame
I only see a PC icon for wireless..but not for console
Can you please post a screen of where it EXACTLY is
( prefer vid )
I will continiu my search for the console console

Posted by: michaelk Mar 20 2008, 04:58 PM

Well, it depends on the desktop you are using which is probably Gnome and it does not appear to be a toolbar item. Where in the menu xterm is located
I do not know at the moment.

Posted by: tweakNsqueak Mar 24 2008, 02:38 AM

I don't know if this will help, but I'm running Mandriva on a KDE desktop and found what appears to be my terminal being called a "terminal emulator" as a panel applet and a "terminal program" listed under "system" in the applications menu (you know, what the "start" button is to Windows). I don't know if this access through the shell may inhibit some UNIX commands as does DOS used through the Windows shell. Who knows. We'll find out eventually. I'll try to be as graphic as possible with the following.

If Ubuntu is simlar, you may find it exactly here:

Select your applications panel
select System
select Terminal Program

In a more universal language, the icon should look like a computer display but with a black screen and probably a white carot (>) and cursor (-).

Another place you might find access is as an applet to the "panel". You know, the panel usually along the bottom of the screen. Placing an applet "button" there will give you easy access whenever you want. My mouse over my "terminal emulator" button says, "Konsole - Terminal Program".

To add an applet to your panel, place your mouse on it, right click and select "panel menu". Then select "add applet to panel". You should then see several applets available to make a shortcut or button available on your panel. You'll probably see in this list the terminal icon called "terminal sessions: menu for starting a terminal emulator". That should be it.

If Ubuntu is nothing like Mandriva, this still might give you an idea of what you might look for. If nothing else, you might want to type "Konsole", "terminal", "terminal emulator" or "terminal session" in your help search engine. Similarly, if the first set of instructions applies to your panel, you can place "help" there the same way. By right-clicking the panel, selecting "panel menu" and "add application to panel" and then "documentation", to add "help" to your panel. Notice there are both applets and applications available to your panel in this way. You'll see what's offered in the list for both. Help should be able to be found the same way through the K menu (applications, tasks and desktop sessions), simply there selecting "documentation" and "help" most likely. I've found "help" most useless on my system so far. Near everything I click on says there's no documentation available, even after building the index. I'm sure I'll find out the story there eventually.

I don't know what type of modem you are trying to install, but if it is dial-up, be aware that Conexant only offers Linux users a driver that one must pay for and is not offered freely in most OS's if not until now. I'm pretty sure it's $20, although I found mine existing on my system one day after literally physically installing a Lucent when I gave up. I don't know if it was on a Utility CD I had paid for and was using, or if I accidently hacked it with some ancient freeware I use to download when I was doing searches. I did several things that day. But when I found it, it was listed as "cnxtinstall" and with one click it installed itself and here I am.

Also, when I first installed my OS, the system asked that I initially select several things, one of which was the type of connection I'd be using. I thought it to be ISP, but it was the last selection, my memory is poor. If all else fails, you might want to try an alternative connection other than what you've selected, through the connection wizard if you think this might be the key. Make sure you write down what you did and where to go back and undo it if you find yourself unsuccessful and you were right in the first place. I've found unfamiliarity makes it really hard to reproduce actions once you've found them and leave. Getting back again can be a brain-rattler.

Anyway, in realizing and finally selecting the proper connection, my OS did a search and told me what modem I had (although I knew), looked for the driver and informed me of its status. (In other words, not there, needing to buy it - with the Lucent, needing to download it.) Finally, with the right connection source and the Conexant driver, I was on my way.

Again, I don't know if any of this will help, as I was only hatched last week myself. Hope something works, regardless. (For both of us, I might add.)

Posted by: tweakNsqueak Mar 24 2008, 06:28 AM

Hi again. I did find out that some installations do need to leave the X environment completely. By this I was sent to the terminal itself. I tried this with my Mandriva 2007 and it worked. I do not know if it works on other systems, but I'm listing it just in case someone's brave enough to try.

First I was told to log out of the Window Manager ("start", log out, end current session), which took me back to my GUI login. Then, using CTRL+ALT+F1 was able to login as root and use my password to get to the command line. Then the call was to shut down the X environment completely by entering one of three commands: service dm stop, telinit 3, or init 3

I chose the obvious: service dm stop

Using Vi the command editor I was told to enter "i" to edit, and to save and exit by hitting ESC. I didn't try to edit anything since I'm still a budding dummy. Still, I found that to exit I had to use the faithful ALT+F4, a common classic command that I had to figure out to use myself. Unfortunately I didn't pursue looking up the Vi commands before I started since editing wasn't my goal. As a result, the editor did not work for me as I had intended and I was trapped for a second. ESC did not throw me into Exit like I had expected and I remembered nothing about Vi from the past. Note to self: Next time I try something, look up EVERYTHING!

Anyway, to return to the X environment, there were also three similar commands for starting it: service dm start, telinit 5, or init 5.

Again I chose the obvious: service dm start

That threw me back onto the GUI login. Then I logged back in and found myself just where I had started, safe on my KDE desktop.

Finally, another success.... due and owing to someone called Hawkwind.

Thanks, Hawk. I feel a little less helpless now.

Posted by: tweakNsqueak Apr 2 2008, 12:59 AM

Thought finishing the aforementioned might be in order.

Here's a link found on that gives commands for Vi.

It was posted some time ago.

Powered by Invision Power Board (
© Invision Power Services (