Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Installation On Wireless Nic (truemobile 1150)

Posted by: CorySmith65 Oct 4 2002, 11:27 AM

Hello,
I am trying to install a truemobile 1150 wireless card on my Linux Red Hat 7.3 machine. The problem is, when I type tar zxvf [name of my driver for the truemobile] it askes me a few questions such as are you sure you want to install this and do you want to install this drive to /usr/src/linux. I chose yes to both and it responded with "there is no directory /usr/src/linux. I then checked to see and it was correct, I only have the directory /usr/src/redhat. I then ran the driver again and told it to install at /usr/src/redhat, the response was the same "there is no directory /usr/src/redhat. I was wondering if you could help me with this problem?
Thanks,
Cory Smith

Posted by: joey Oct 4 2002, 12:06 PM

Hi Cory,

I don't have any wireless devices nor any expierience with them but I believe that the installer is looking for the Linux Kernel Source which is normally located at /usr/src/linux

I believe a default install of Red Hat Linux will not include the kernel source however there should be a kernel-source .rpm file on your cdrom.

You should also be able to find it at the following URL incase you dont have a cdrom handy.

ftp://ftp.rpmfind.net/linux/redhat/7.3/en/os/i386/RedHat/RPMS

The file you'll want is kernel-source-2.4.18-3.i386.rpm

After you install it (rpm -Uvh kernel-source-2.4.18-3.i386.rpm) try running your driver program again and see what it says.

Posted by: CorySmith65 Oct 4 2002, 01:23 PM

Hey Joey,
First off, thanks for your help! Secondly, I downloaded that file and tried installing it. here is what i got, "kernel-source-2.4.18.3.i386.rp: read manifest failed: Success "
then i tried installing the driver again and it gave me the same message. it says "linux source tree /usr/src/linux is incomplete or missing

thanks again,
Cory

Posted by: joey Oct 4 2002, 02:31 PM

After running the rpm -Uvh command you should have seen something like:


Kernel Source #################################


If you didn't see that then the file did not install correctly.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)