Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Chat Script Problems

Posted by: steve-o Oct 1 2002, 01:25 PM

After the old modem got fried, a new one was installed (Zoom V.92 external).
The modem responds, inits and dials with minicom, but a chat script fails, as the modem never replies to chat. Using chat -v, the log basically shows

send ATZ
expect OK

Anyone have any ideas?

This is on a RedHat 7.2 box.

Posted by: joey Oct 1 2002, 01:31 PM

what chatscript is this? Have you tried ppp-up?

Posted by: steve-o Oct 1 2002, 01:48 PM

since ppp invokes chat, I have to get chat to work first. so to test the chat script I'm just running:

chat -v -f my-chat-script

the chat script itself is very basic (this is not exact)

"OK-+++c-OK" ATH0
"" ATZ
OK ATS11=50L3 (more init stuff here)
OK ATDT (phone number)

Also, I notice when I run chat, if I have any init commands in the string prefaced with an ampersand they create an error. For example an init string that contains &c1 gives me an error about an invalid command.

Posted by: joey Oct 1 2002, 02:08 PM

Try ppp-up.

Posted by: steve-o Oct 1 2002, 02:58 PM

I've done that. ppp-up does not work. It runs the chat script and logs a chat script error. That's why I'm trying to break it down and see where the failure is.
Since all ppp-up does is invoke pppd with a connect option, which in turns spawns chat, I'm skipping the pppd process and running chat directly from the shell, with identical command line options to trace the error. Doing that gives me the 'alarm' and 'failure' messages in /var/log/messages, and I can watch the modem front panel and see that nothing happens. But minicom works fine.

Powered by Invision Power Board (
© Invision Power Services (