Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Help With Xwindows

Posted by: Prometheus Nov 12 2002, 05:15 AM

ok, so i had a friend over who said he could accelerate my graphics card for me.....*sigh*. after an hour of him tromping around the web he ends up downloading and installing new drivers for my current video card (voodoo banshee), the end result being I'm now getting all manner of really lame error messages when I try to run startx as any other user besides root (including other superuser accounts). I'm about two steps away from re-installing my O/S here. I've already disected the shell script that installed the drivers, it appears to have modified XFree86.conf. so I replaced that with the backup. no dice. so I ran Xconfigurator. no dice. so I ran setup. no dice. at this point every time I tried running xwindows as another user (which had worked like a charm before all this happened) I got a fatal server error: unable to open /var/logs/xfree86.0.log. so I checked the directory and the file was right there where it's supposed to bo, so I changed the permissions on it to Read-write-execute for everyone, then tried running startx as a normal user again. this time I got unable to open bin/mem : permission denied. now I'm just pissed off at the prospect of having to re-install linux, especially since it's my fault for letting someone else screw around as root on my computer (even though I thought he had more experience than I did). just to add insult to injury I managed to inadvertently k-line myself from three irc servers for irc-ing as root (was after help, didn't know that wasn't allowed). anyway, all whining aside, anyone have suggestions? or should I just go ahead and blow away the current install and start with a clean slate?

Posted by: Corey Nov 13 2002, 08:33 AM

A little bit more information may be helpfull when attempting to assist you. For example, the exact errors you are getting as well as the distribution of linux you are running and the version of XFree86 you are running. I own a voodoo banshee, and I have had no problems with it since I purchased it.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)