Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Apache Running But Not Responding

Posted by: salecta Nov 11 2002, 05:46 AM

unsure.gif I installed RedHat Linux 8.0 on a PC. I think its kernal 2.14.
Apache was installed with it, version 2.040 I think. I have started Apache with /usr/sbin/apachectl -k start
The error log /var/log/httpd/error_log said it was operating normally.

We are not using SSL, but the ssl_error_log gave warnings about RSA.

The Linux machine has a static ip. I was able to ping the server from my other machine. I tried browsing to it though, and it did not work. I typed the server's IP address into the browser URL line.

In the httpd.conf, I have set the Listen to 80 and ServerName to the server's (internal network) IP address. The error log does not show anthing to say anything wrong, the access_log stays empty.

Can anyone tell me why Apache is not serving.

Posted by: Corey Nov 11 2002, 07:12 AM

First off, try to restart the server with /usr/sbin/apachectl restart . As far as my memory serves me, when you append the '-k' on the command line for a daemon, it usually stops the service, not starts. The second thing is, for arguments sake, try accessing the server on secure, that is, in the URL bar, enter in https://theip and see if you connect. It might be that apache is running in secure ssl mode rather then regular modes.

Posted by: salecta Nov 11 2002, 06:45 PM

I tried https://192.168.0.74 It didn't work. If it is using SSL, how do I make it not use SSL?

The entries in the error_log are (including a restart):

[Time...] Apache/2.0.40 (Red Hat Linux) Configured -- resuming normal operations
[Time...] SIGHUP received. Attempting to restart
[Time...] Digest: generating secret digest authentication ...
[Time...] Digest: Done
[Time...] Apache/2.0.40 (Red Hat Linux) Configured -- resuming normal operations

And the entries in ssl_error_log are (these two warnings appear at the time I do a restart)
[Time...] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Time...] [warn] RSA server certificate is a CommonName (CN) 'localhost.localdomain' does NOT match server name!?

The other logs access_log, ssl_access_log and ssl_request_log remain empty.

Posted by: chrisw Nov 13 2002, 09:31 AM

Possibly since the
[Time...] [warn] RSA server certificate is a CommonName (CN) 'localhost.localdomain' does NOT match server name!?

this might be saying since the names dont match that apache
wont start....

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)