Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Ttysnoop Password Issue

Posted by: Hobb3s Sep 30 2002, 03:52 PM

I have just recently installed ttysnoop-0.12c-5.i386
Only there is one problem I can not figure out. When I go to connect to a tty I get this.
**********
Connected to ttyp0 snoop server...
Ctrl+'' (ASCII 28) to suspend, Ctrl+'-' (ASCII 31) to terminate.
Snoop password:
Password incorrect.

Back at local tty.
************

Basically it won't accept my password (root or user) and I'm at a loss on how to fix it.
Thanks for any help in advance.

Posted by: joey Sep 30 2002, 07:34 PM

It's been ages since I tried out ttysnoop.

What distribution are you running this on? I have a test install of mandrake 9.0 going so I'll give it a whirl tomorrow after work and see what I can come up with.

Thanks

Posted by: Hobb3s Sep 30 2002, 08:50 PM

Thanks for the reply. However I just figured out the problem. It was something to do with version c-5 not liking shadow passwords. So I uninstalled that version and found a newer c-9 version that works perfectly. Thanks for the offer of help, appreciated.
I'm running it on Trustix Secure Linux 1.5.

Posted by: joey Oct 1 2002, 06:05 AM

Hey I have an idea. We have a ttysnoop guide on the web site (On our guides page) however the person who originally wrote the guide is no longer around. Would you like to take ownership of it and give it a good updating? smile.gif

Posted by: theGeeko61 Dec 23 2011, 02:27 AM

I see that it's been years since anyone was in here... but, I've wiped away the electronic cobwebs and install ttysnoop on my Ubuntu 11.10 box. I installed from the repository and it is version 0.12d-4.

I am having the problem which was described in this post.

I have installed and modified my tty?.conf files in the /etc/init. After rebooting and logging into my GUI (Gnome3/Gnome Shell), I verify that no files are in /var/spool/ttysnoop.

I then login on TTY1 and go back to the gui and verify that there is an entry in /var/spool/ttysnoop. Indeed, there is a socket entry, "2=".

Just to be meticulous, I login on TTY2 and return to the gui. Yes, I now have "2=" and "3=" in /var/spool/ttysnoop.

It appears that the setup was successful.

So, I try running (first as root, then as an admin user) ttysnoop.

I run "ttysnoop 2" and get the following:

Connected to /dev/pts/2 snoop server...
Ctrl+'\' (ASCII 28) to suspend, Ctrl+'-' (ASCII 31) to terminate.
Snoop password:

But, when I enter the password, it ttysnoop replies:

Password incorrect.

Back at local tty.

Since I am using the same user that I had logged in with on TTY1, I know that I have the correct password. Is there something more?

I shall appreciate any help that can be provided...

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)