Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Lost Network Connection After Compiling Kernel

Posted by: KarrottoP Oct 31 2002, 10:10 AM

I have just switched from Redhat to Debian and found that the easiest way to get the graphics drivers for my NVidia card working was to recompile the kernel, besides, it is good to have a custom kernel anyway. When I first installed Debian I could not get into X but I was able to get online with elinks, so I know that my network was responding correctly. After I compiled the kenrel I was no longer able to get online, by booting from either the origninal kernel or form the newly compiled kernel. This leads me to believe that it is not a driver problem. So now I am stuck without an internet connection, or a connection to my other computers. Maybe somebody knows the problem, but it is odd that it would work pre-compile an not either post-compile, that is what is really getting me....here is the stats on my connection.

ADSL router (modem) ---> Linksys DHCP/Gateway router ---> Computer
WAN 192.168.1.1 ?

My computer should obtain it address automajically from the Linksys router and then also get its internet access directly from it. This has worked in Redhat 7.3 and 8.0 and Mandrake 8 as well as in my initial debian installation.

Thanks for any help. By the way, before somebody suggests it tongue.gif my reslov.conf is fine and my ifconfig appears fine as well.

Posted by: joey Oct 31 2002, 12:38 PM

what does route say

perhaps the default gateway isnt specified.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)