Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Can Anybody Help?

Posted by: flandercan Oct 25 2002, 03:58 PM

Hello people, I have a problem maybe someone can help me with or point me in the roight direction?

I am running suse linux 7.1 kernal 2.4 , all works ok, however i have tried to install OPERA or NETSCAPE and am having the same problem, when i attempt to run the apps i get the following error

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
opera: cannot connect to X server :0

I have completely re-installed and still get the same error??

thanks

Posted by: styker Oct 27 2002, 05:48 AM

Make sure your running the browser as the same user that ran "startx". I'm not sure about suse X security measures, I'll try to look into it if that doesn't work, let me know.

Posted by: Corey Oct 27 2002, 12:15 PM

Or, you can simply issue the following command from your x-terminal-emulator before you 'su' to another user: xhost +localhost , that should give the permission to access the active X session.

Posted by: ifman Nov 11 2002, 02:28 PM

tourettes' post should fix it, but also you can do
xhost +

just make sure you have your firewall setup if you do that as you allow others to use your xserver remotely.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)