Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Trouble installing ALSA driver

Posted by: 0106mas Oct 17 2014, 02:35 PM

Im trying to install realtek high definition audio driver but have some problems and the sound is completely gone now. My OS is Linuxmint17 64 bit.Commands I run:

cd /home/marcell/Downloads
tar jxpvf LinuxPkg_5.18rc8.tar.bz2
cd /home/marcell/Downloads/Rt-Linux-HDaudio-5.18
tar jxpvf alsa-driver-RTv5.18rc8.tar.bz2
cd /home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa
make install

then i get this error after 'make':

/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb/misc/ua101.c: In function ‘ua101_disconnect’:
/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb/misc/ua101.c:1357:2: error: implicit declaration of function ‘__list_for_each’ [-Werror=implicit-function-declaration]
  __list_for_each(midi, &ua->midi_list)
/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb/misc/ua101.c:1358:3: error: expected ‘;’ before ‘snd_usbmidi_disconnect’
cc1: some warnings being treated as errors
make[4]: *** [/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb/misc/ua101.o] Error 1
make[3]: *** [/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb/misc] Error 2
make[2]: *** [/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/usb] Error 2
make[1]: *** [_module_/home/marcell/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-24-generic'
make: *** [compile] Error 2

i tried uninstalling and then reinstalling libasound but that didnt help either. Amixer does not recognize any sound cards but the inxi -Ax script returned the following:

Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio bus-ID: 00:1b.0
Card-2: NVIDIA GF106 High Definition Audio Controller bus-ID: 02:00.1

Initially I had sound set to default (pulseaudio) and things went mute after I tried to configure realtek. Maybe it realy is just a compiler error and not something else, then it could easily be solved by correcting a few syntax errors.
Thanks for any help and sorry for long post! biggrin.gif

Powered by Invision Power Board (
© Invision Power Services (