Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Printing from Ubuntu 13.04 to win 7

Posted by: Clayman1000x Mar 30 2014, 06:26 PM

I have been trying to get my Ubuntu laptop, wireless, to print to a Canon printer hooked to my win 7 machine, printer sharing is on and workgroup is the same on Ubuntu and Win 7. I tried a few other self help posts but I don't have "Printer" listed under System Tools/Administration/, I see "Network Tools" and "Software Updater" but not "Printer". So I have no way I can see to setup a network printer. I even went to "Printers" under System Settings to add the printer but it couldn't see any printer and I reinstalled Samba through Synaptic Package Manager but no luck.
Anyone have any ideas?

Posted by: michaelk Mar 30 2014, 08:43 PM

What version of Ubuntu are you running and what is the model number of your Canon printer?
The printing tool may not be in a menu. Try this in a terminal:
sudo system-config-printer-gnome

If you get an error that file can not be found etc. then you can install it via
sudo apt-get install system-config-printer-gnome

What happens when you try this URL in your internet browser
localhost:631

If you get a page not found error then install cups via
sudo apt-get install cups

You should also verify that samba is installed. From a terminal try the command
smbclient.

To install samba.
sudo apt-get install samba

Next you will need to install the driver for your printer assuming it is supported. Without knowing the model number I can not provide any help. Once the driver is installed you can run the printer config menu to add the printer.
You will want to select "Windows Printer via SAMBA" and go through the rest by selecting the server/printer and driver.


Posted by: Clayman1000x Mar 31 2014, 08:44 AM

I am running Ubuntu 13.04 w/Cairo-Dock, Canon PIXMA IP2700, thanks for responding. I now have it fixed and working. Most of the things you wanted me to try I had already tried but still couldn't connect it. Whats funny is this, I run Cairo-Dock ver 3.3.2. I logged out of my desktop with Cairo and logged back in on my Unity desktop, I then found the network printer setup and all I needed. I copied the IP address from my router setup page and it found it and printed a test page, I then logged out of the Unity desktop and back in the Cairo desktop and it still printed. Whod a thunk the actual desktop would make a difference here. But thanks for being there.

Posted by: michaelk Mar 31 2014, 09:41 AM

Glad you got it working.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)