Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ Using Grub to boot Linux from Live USB

Posted by: HenryDodson Jun 2 2013, 05:48 PM


I can't manage to figure out how to get Grub to boot Sugar on a Stick (Fedora) from a USB. I have been using 'Grub Customizer' in Ubuntu 12.04 (Edubunto). I have been messing with the config all afternoon, via 'Grub Customizer', and the best I can do is getting different errors. I feel like there is something about booting Fedora on a USB via Grub that I am not understanding. I have found instructions for booting Ubunto from a USB with grub but they didn't work for SoaS.

I am trying to setup a laptop for a child. I wanted to have the primary OS be edubunto, but also give them the option to use SoaS if they wanted. I also wanted them to have a SoaS flash drive when they visited family members, so they could use borrowed computers safely. Unfortunately the BIOS on the laptop I'm using resets the boot priority to its default (HDD->USB) whenever I unplug the flash drive, so just changing the boot priority wasn't an option. I thought Grub was a good alternative, if only I could get SoaS to load from it...

also, my BIOS does allow booting from USB drives, so I'm pretty sure Grub not being able to see the SoaS USB drive isn't the problem.


here is my latest failure:

set root='(hd2,0)'
search --no-floppy --fs-uuid --set 007A-E647
linux syslinux/vmlinuz0 root=UUID=007A-E647
initrd syslinux/initrd0.img

Also tried hd(0,1) and hd(1,0) as root.
And tried putting vmlinuz0 and intrd0.img on the hd , in /boot/, and having Grub calling them from there.
Tried combinations of the above, not sure if I tried them all, though.

Posted by: HenryDodson Jun 2 2013, 10:12 PM


I made this way more complcated than it needed to be. Here is the solution:

set root='(hd1,1)' ***This was the correct location to boot my USB flash drive from***
chainloader +1 ***my flash drive was already bootable so I just needed grub to hand off to my usb stick***

I dont know why the bootable partition on my usb stick was (hd1,1) vs (hd1,0) but it was. Also using the command line ('c' @ the grub2 menu) was much faster for expermintation than editing the config in 'Grub Customizer' and rebooting to test my commands.

Posted by: michaelk Jun 3 2013, 07:22 AM

Well done and thanks for posting back with the solution.

Powered by Invision Power Board (
© Invision Power Services (