Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ problem with graphic interface.

Posted by: bambinos May 16 2013, 02:55 AM

Hi all,
i am new to debian so please whoever replies be really thorough.
i got a raspberry and it started with visual enviroment.
i tried to drop it so i would have only the command line, so i run through some topics in here and in other sites and i reach in that going into the etc/inittab file and changing the line
id:2:initdefault to id:3:initdefault i would succeed it.
i did it and then restarted my Raspberry. it started loading but in some point it says : "entering runlevel". From 0 to 6 nothing works saying "no more proccesses in that runlevel".
tell me what to do at least to get to the previous state with the graphic enviroment.
thx a lot.

Posted by: michaelk May 16 2013, 06:28 PM

Not all linux distributions use runlevels in the same manner. debian does not differentiate between runlevels 2-5 vs Redhat or SuSE.


For what its worth to disable the login manager from automatically running at boot up, run the following command as root

#update-rc.d -f gdm remove

Replace gdm with kdm or xdm if they are what you use.
To start X manually, you would then have to login at the command prompt and enter the command startx.
To reset your login manager so that it runs at boot up, do

#update-rc.d -f gdm defaults

If the system will not boot you might be able to repair by plugging the SD card into another computer and editing the inittab file via a live CD.

Posted by: bambinos May 22 2013, 03:57 AM

So thx a lot for answering.
after a lot i manage to fix the file via live cd. i restore the whole inittab file with another i had from a second sd card.
the real problem yet remains so could you tell me plz how can i drop the graphical interface? i only want the command line to appear. thx again.

Posted by: michaelk May 22 2013, 06:49 AM

See my instructions from the other post.

Powered by Invision Power Board (
© Invision Power Services (