Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Technical Support _ minidlna on Mint 14 - config problems

Posted by: watty62 Jan 26 2013, 11:07 AM


I've installed minidlna on Linux Mint 14.

Originally when I ran the command:

sudo service minidlna start

I got the following errors:

[2013/01/26 14:07:34] getifaddr.c:73: error: ioctl(s, SIOCGIFADDR, ...): No such device
[2013/01/26 14:07:34] minidlna.c:474: error: Media directory "/media/HardDrive/music # Use A, P, and V to restrict media 'type' in directory" not accessible! [No such file or directory]
[2013/01/26 14:07:34] utils.c:265: warn: make_dir: cannot create directory '/var/cache/minidlna # Needs to be un-commented']
[2013/01/26 14:07:34] minidlna.c:529: fatal: Database path not accessible! [/var/cache/minidlna # Needs to be un-commented]

I worked out that by commenting out the line


in minidlna.conf gets rid of the error.

I'm still stuck with the others.

The media directory one is odd.

The location of my media is an external hard drive which is mounted on boot as /media/HardDrive/ I've checked and the path to that is OK.
so the config line for Audio is
media_dir=A, /media/HardDrive/Music

and it returns the error above.

I ran
chmod -R 755 /media/HardDrive to make sure permissions were ok - but still no joy.

I changed the audio direct line to

media_dir=A, /home/Watty/Music but that returned the same error.

If I comment out the line
media_dir=A , ......etc altogether

then it doesn't choke on subsequent lines
media_dir=P, /media/HardDrive/pictures

media_dir=V, /media/HardDrive/video

which is odd.

Lastly I haven't yet looked at the final error but appears to have a permissions issue in making or writing to
yet it does exist.

Thanks for any pointers!

Thanks for any help


Posted by: jasmine Jun 19 2013, 01:42 AM

I really like your way of expressing the opinion and sharing the information.

Powered by Invision Power Board (
© Invision Power Services (