Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Programming in Linux _ Start an .exe file in Linux using Putty/ssh

Posted by: Mpee Sep 7 2008, 06:52 AM

Hello, my friends hierd and dedicate server to host an game server, for 1 - 2 weeks ago i finished the work (get the website finished etc). But now i cant start the .exe file for the server, i have tried to get itn work for over 2 weeks now without any succes. I know there is programs that can open .exe file in linux using command panel (Putty or ssh) When i write /root/***/***.exe i just get respond permission denied and if this is for any help -rw-r--r-- . Using Linux Fedora
If any got a tutorial or know how to do please post it here.

Best regards
Måns

Posted by: michaelk Sep 7 2008, 08:36 AM

What game server are you tring to run?
linux can not natively run a windows exe file. You need to use wine.
If you are trying to run x applications via putty you will need to enable x11 forwarding and install cygwin.

Posted by: Mpee Sep 8 2008, 09:01 AM

QUOTE (michaelk @ Sep 7 2008, 02:36 PM) *
What game server are you tring to run?
linux can not natively run a windows exe file. You need to use wine.
If you are trying to run x applications via putty you will need to enable x11 forwarding and install cygwin.


It is an Open Tibia server, i have tryed to use wine without any succes, but i get this message whern trying;
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.

Well, now i figured out how to enable X11 Forwarding since that wasent so hard, but how to install cygwin with commands ? ;S

Posted by: michaelk Sep 8 2008, 11:37 AM

Howtos and other options:
http://www.cs.caltech.edu/courses/cs11/misc/xwindows.html
http://www.linux-tip.net/cms/content/view/302/26/
http://dragonwall.net/xdeep-putty.html

Posted by: Mpee Sep 8 2008, 01:18 PM

QUOTE (michaelk @ Sep 8 2008, 05:37 PM) *
Howtos and other options:
http://www.cs.caltech.edu/courses/cs11/misc/xwindows.html
http://www.linux-tip.net/cms/content/view/302/26/
http://dragonwall.net/xdeep-putty.html


I read through the links, downloaded x-deep/32, drove it in the bakground, configured it as the tutorial said, but i still getting same error;
[root@rbi0214 ~]# wine /root/eclipse/eclipse.exe
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.

Posted by: michaelk Sep 9 2008, 07:16 AM

If you exported the display correctly then it could be a wine issue of which I do not have any real experience using.

Posted by: Mpee Sep 12 2008, 10:29 AM

QUOTE (michaelk @ Sep 9 2008, 01:16 PM) *
If you exported the display correctly then it could be a wine issue of which I do not have any real experience using.

Posted by: Mpee Sep 12 2008, 10:29 AM

QUOTE (michaelk @ Sep 9 2008, 01:16 PM) *
If you exported the display correctly then it could be a wine issue of which I do not have any real experience using.


Well, i will try do do it again then, maby did it wrong --

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)