Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Programming in Linux _ Using wget from a Telnet Session

Posted by: BillyBarty Aug 23 2006, 12:40 PM

I have a prototype device that I am working on that is running some sort of Linux. I have it connected to my desktop PC (XP pro) via a USB connection with the USB ports on each end (both my desktop and the prototype) configured for USB LAN. So I am not going through the internet, but rather have a simple computer to computer USB LAN connection. Using this setup, I am able to Telnet to the prototype from my desktop PC. The prototype allows me to login as "root" and I can browse it's file system no problem. I can also ping the desktop's USB LAN connection from the Telnet session. So far so good. My goal is to copy files from my desktop to the prototype using wget, so I set up an FTP server on my desktop to facilitate this. I would like to go this route because it seems like the only way to bring files over without having to load and start SSH on the prototype. I have no control over what the prototype will support, though it seems to support at least some form of wget but is not currently supporting SSH. This being the case, I can't (for instance) use PuTTY's PSFTP program to transfer files over, because that app uses SSH. I have no problem installing what I need on my desktop PC (like the aforementioned FTP server), but getting the prototype owners to add services (such as SSH) could be difficult (limited and coveted computing power of the prototype plus organizational red tape). So, I keep coming back to wget as the best theoretical solution. However, so far I have had no luck. Here is what I think is the pertinent information:

desktop USB LAN IP: 192.168.1.5 (fixed)
prototype USB LAN IP: 192.168.1.2 (fixed)
FTP server running on my XP pro desktop: FileZilla 0.9.18 - set up to listen on port 21

Here is the command I try after Telneting to the prototype along with the subsequent response:

# wget ftp://192.168.1.5
Connecting to 192.168.1.5[192.168.1.5]:21
wget: Unable to connect to remote host (192.168.1.5): Connection timed out

I am able to connect to my ftp server locally (from my desktop) via Internet Explorer. I haven't tried from an outside computer, because I doubt our firewall would allow it and because I don't think such an exercise would shed any light on my wget problem.

Am I all wet on even trying this? Will wget only work if the prototype has access to the internet (which it does not)?

Any response is greatly appreciated.

Thanks,
Bill

Posted by: BillyBarty Aug 24 2006, 05:31 PM

OK. I figured this out after much trial and error. I can't use port 21 (the default) to listen on. Once I changed this in FileZilla from 21 to something greater than or equal to 1024, it worked fine. It seems that anything below 1024 won't work with my setup. I tried 1023 - no dice; 1024 - jackpot. I hope my experience might help someone else out there.

Posted by: michaelk Aug 24 2006, 05:41 PM

Make sure that you have disabled any filewall settings on the XP desktop for the LAN adapter.

You also need to specify a filename or directory

Posted by: DS2K3 Aug 26 2006, 03:22 AM

Yup - Ports below 1024 are reserved for root to use. > 1024 are available to everyone.

D

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)