Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Programming in Linux _ Pthreads In Fedora

Posted by: smas Aug 30 2004, 05:53 AM

I'm running Fedora 2 (I think) and I can't get a simple program using pthreads to work. I don't think the libc libraries installed is pthread capable. Could this be the case? If so, how do I download and install the correct libraries?

regards,
S

Posted by: Hemant Aug 30 2004, 06:06 AM

This should not be the case...have you tried compiling with "-lpthreads" or "-lpthread"
(Actually i forgot whether it was pthread or pthreads and i am replying from a windows based machine)

Posted by: smas Aug 30 2004, 06:43 PM

I'll give that a shot... the reason why I thought libc on my box might not be pthread capable is because I looked at the glibc site and noticed that pthreads is actually an add-on to the base glibc library (as is cryptography).

S

Posted by: smas Aug 31 2004, 05:48 PM

It worked, thanks. biggrin.gif

Posted by: Hemant Sep 1 2004, 03:55 AM

Welcome.....

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)