Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Motherboard incompatible with Linux

Posted by: Jackie Jan 23 2008, 12:48 PM

I have an Intel DG33FB motherboard that is listed by Intel as not being compatible with Linux.
I have tried loading every 64 bit Distro I could find and they all respond the same way.
Media check is good and the install process goes great until it starts to load packages onto the hard drive.
At some point, but never the same point, the loading process freezes and I have to reboot and start over.
I only got one error message from one Distro that said "interupt interference". Usually I get my scroll lock
and caps lock leds to flash in unison when the loading hangs, otherwise there are no other fault indications.
Another odd thing is that the installs all want to list my HDA as an SDA and I don't have a SCSI setup, just SATA.
BTW, I tried every method of installing that I could find.

So, does anyone have a suggestion as to how I can get Linux loaded on this setup?

Intel DG33FB motherboard
Intel X6850 CPU @ 3ghz
1333 FSB
PCI-E
Nvidia 7300LE (PCI-Ex16)
WD 250 gbyte SATA 2 hard drive.
Patriot DDR2 6400 (1 gbyte x 2) dual channel
Conexant modem
(2) Lite-On CD/DVD SATA 2 drives with DL and Lightscrribe.
Samsung floppy
All peripheals are usb connected.


Thanks for your help

Posted by: michaelk Jan 23 2008, 02:24 PM

It takes some time for support to catch up with newer hardware. I would try pci=nommconf kernel option.

Have you tried a 32bit distribution?

The SATA module uses the SCSI subsystem so it will show up as a sda device. In fact the latest libsata treats all storage devices as SCSI including IDE.

Posted by: Jackie Jan 23 2008, 04:25 PM

I tried one 32 bit Distro and it halted with an error message of "This is not a 32 bit machine" and would not load.
Another 32 bit Distro I tried just gave me a blank screen right after clicking on Install.

Thanks for the SATA update, I thought my hardware was being detected incorrectly and that would be my loading problem.

I'll try the kernal option later on. I need a break to get my frustration level back to normal ;^)


QUOTE (michaelk @ Jan 23 2008, 11:24 AM) *
It takes some time for support to catch up with newer hardware. I would try pci=nommconf kernel option.

Have you tried a 32bit distribution?

The SATA module uses the SCSI subsystem so it will show up as a sda device. In fact the latest libsata treats all storage devices as SCSI including IDE.

Posted by: Jackie Jan 24 2008, 03:01 PM

I tried the pci=nommconf on the distros. I could tell it helped with the ones
that gave me a blank screen, but those and the others all crashed the same way.

error msg:

kernal panic - not syncing:Aiee, killing interrupt handler

Posted by: michaelk Jan 24 2008, 03:12 PM

Check out
http://www.both.org/?page_id=18
http://www.suseforums.net/index.php?showtopic=39385&pid=221909&st=0&#entry221909

Might want to try the latest Fedora. From the various threads all stated that you should make sure you have the latest BIOS.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)