Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Multiple problems

Posted by: mirke Dec 18 2007, 06:34 PM

Hello there to free community army smile.gif

I've installed Slack 12.0 and here are my problems

Problem 1) I have logitech quickcam express, and I found and installed driver for it on sourceforge.net but here is problem

I load module with
> insmod quickcam.ko
>modprobe quickcam
and when I type
> modinfo quickcam

I get

filename: /lib/modules/2.6.23.11/misc/quickcam.ko
license: GPL
author: See README
description: Logitech QuickCam USB driver
alias: usb:v046Dp0870d*dc*dsc*dp*ic*isc*ip*
alias: usb:v046Dp0850d*dc*dsc*dp*ic*isc*ip*
alias: usb:v046Dp0840d*dc*dsc*dp*ic*isc*ip*
depends:
vermagic: 2.6.23.11 mod_unload PENTIUMIII
parm: qcdebug:Sets the debug output (bitfield) (int)
parm: keepsettings:Keep picture settings across one open to another (0-1) (int)
parm: settle:Maximum number of frames to wait picture brightness to settle (0-2 55) (int)
parm: subsample:Sets subsampling (0-1) (int)
parm: compress:Enable compressed mode (0-1) (int)
parm: frameskip:How frequently capture frames (0-10) (int)
parm: quality:Sets the picture quality (0-5) (int)
parm: adaptive:Automatic adaptive brightness control (0-1) (int)
parm: equalize:Equalize image (0-1) (int)
parm: userlut:Apply user-specified lookup-table (0-1) (int)
parm: retryerrors:Retry if image capture fails, otherwise return error code (0- 1) (int)
parm: compatible:Enable workaround for bugs in application programs (bitfield) (int)
parm: video_nr:Set videodevice number (/dev/videoX) (int)

but I don't have /dev/video

Problem 2) I have WinFast XP 2000 tv tuner and it seems when I import some options in kernel it seems it works fine, but I cannot install tvtime from archive tar.gz (make dosen't work it seems it is problem with gcc version mine is 4.1.2), then I've installed it from tgz package (Slack type) and when I try to start it it blocks my computer. No single thing works.

And yes I can choose WinFast XP 2000 to be my web cam but as you can guess it doesn't work correctly.

Posted by: matt Apr 11 2008, 09:02 AM

Corey has written a guide on getting that spec card to work. http://www.linuxhelp.net/guides/tvtuner/ It worked for me with slackware 12. as for TvTime I coulnt not get it to compile as well without errors but the version on linuxpackages.net works fine. Try testing your card in MythTV as well. I know dagmar from the dropline project has tgz's built up for MythTV with every dependency package and add on module . http://dagmar.droplinegnome.org/slackware/MythTV/
Once you get your kernel patched with coreys guide and everything recompiled. download those packages, install, and Enjoy.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)