Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ a big toughy, im a techy and cant figure it out!!!

Posted by: matty Sep 29 2006, 04:41 PM

okay, here is the riddle, get your thinking hat on!

any linux boot that i test shows three consecutive errors before typing its boot steps into the screen. they are:
PCI: unable to locate resource in location 0 for device 0000:01:00.1
PCI: unable to locate resource in location 1 for device 0000:01:00.1
PCI: unable to locate resource in location 2 for device 0000:01:00.1
or something very very close to that exact text....

SO, i figured that i had an error in one of my PCI devices (logically) and begin with removal of my graphics card, (FYI next to nothing works in any linux and system freezes are frequent but not fatal) and HEY it worked, i boot up into linux and the three error messages are gone! everything works!!!! yay! so im an X-windows user and i had done alot of overclocking to my gfx card, so i figure that was the problem. So i grab an older card outta my closet and plug-er in. then the BRAIN BUSTER.... EXACT--SAME--ERRORS strange eh? i know..... so i think, hmm, its odd that it cannot find the same resource with the same device ID thingy at the end, so then i think for a moment and logically conclude that it is my PCI slot. sound correct eh? NOPE, i remove all other pci devices and move the card down one space, then another BRAIN BUSTER... EXACT--SAME-ERRORS!!!!! damn, its very odd that i can get these exact same error results from completely unalike graphics cards AND different pci slots (i only have three, i tried all of them) so then i was stumped.... completely done, so i say fuck it, since i have absolutely no OS on my drive right now i just want to get on. so i leave the card out and use my onboard gfx. great, so after i test another live boot on ubuntu and phlak, everything is smooth, im happy, still confused but happy.... okay back to the brain buster-- so i stat the install of ubuntu, everything is fine, it all works, all my packages are downloaded, all 2 gigs of em, damnit, lol but anyway i get it all done, but when i reboot to login i get a command line saying:
Matt- Login:
(im matt by the way)
and when i typed my login (matt) and pressed enter i got the line saying:
BUT* i cannot type anything after password??? after 3 seconds (always 3 seconds) it suddenly returns to me
incorrect login
so i try again, nope i can only type my login and then nothing at passowrd.... strange i think, so then more confusing shit, i try again and a screen suddenly pops up saying there wuz an error and that the x-server cannot be loaded.... SO i view the error details and it says there is no such directory.... hmm then i start to thinkin, and i noticed that before i removed my gfx card i quite often got errors saying the same thing (many different directories though) and then im really stuck..... soooo, i think maybe its my HD, and try installing on my alternate HD, and violla, here i am in ubuntu.... BUT, still no gfx card..... is there a connection??? I DONT KNOW!!! im far to confused now to tell if that is two problems or just one..... so:


Posted by: g33k Sep 30 2006, 07:16 AM

Try booting from the other harddisk again..and give us the exact error details (which file is missing or which directory is not present)

BUT* i cannot type anything after password??? after 3 seconds (always 3 seconds) it suddenly returns to me
incorrect login

For security reasons linux doesn't echo a password character for the password you type. Just type it and press Return. If your password is correct you should get a command prompt. Then you may try to start the X using :

Posted by: matty Sep 30 2006, 07:45 PM

sorry, but do you want the error fedback from the PCI problem, or the error that the ubuntu installer gave me when i tried to log in, about the X server??

Posted by: g33k Oct 1 2006, 02:35 AM

The error which comes when X-Server starts..

Powered by Invision Power Board (
© Invision Power Services (