Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Reading a Windows HDD

Posted by: jackdw Aug 22 2006, 05:08 PM

My friends computer recently took a turn for the worst. It's a windows XP computer, I've tried everything I can to make it boot but it won't.
My friend uses Linux alot, I never thought much of it until now. I asked him if it was possible for Linux to read a NTFS disk. He said yes, with linux 10.1, which I borrowed off him. Ok, I installed it etc great, it works, looks good.

This is what I need to do.

Grab a few folders with very important work on from his hard drive and network it to my windows PC which has enough space for the files. My friend said it should work, I had all my window's PC shares up, created a folder, was about to copy and paste his files from '40g media' and it comes up with "Permissions denied"

How can I access this drive and save his work?

Come on, make me like linux biggrin.gif


EDIT: I'm a real newbie at all this linux so I'll tell you this. It's Linkux 10.1 and I use KDE 3.5 and the computer it's on has a 750mhz AMD duron, 512mb of RAM. A 18gb hard drive with a few partitions, 5gb to linux and of course the 40gb hard drive I'm trying to get files off.

Posted by: michaelk Aug 22 2006, 06:32 PM

I've never heard of linkux. Do you know if it is based on another distribution?
BTW there is no such thing as linux 10.1.

Were you trying to copy files via windows explorer to your PC or someother file transfer application? Or did you mount the windows shares on your linux PC? I assume its the latter. How did you configure your shares and samba? Not enough information provided but you probably need to add a smb password.

smbpasswd -a user (make it your regular user)

Posted by: jackdw Aug 22 2006, 07:42 PM

Look I'm real sorry I'm a complete newbie at this! I'll try and tell you what I've got.

The case I have says 'SUSE Linux 10.1'

Basically, I loaded this KDE, Linux, whatever you want to call it, clicked My Computer, saw '40gb media', the hard drive I'm trying to backup is 40gb so that's it. I click on it to try and access it, and it says "Permissions denied". The files haven't tounced my personal computer yet (the Windows XP only one)
I was hoping to get it networked so I could copy and paste it from linux to a shared windows folder.

I haven't got a clue what samba or a smb password are.

I have the root user, and a normal user. Neither can access it without "Permissions denied".

Sorry I don't understand all this very well..

Posted by: DS2K3 Aug 26 2006, 03:34 AM

Ok - You have SUSE 10.1.

KDE is the software that controls the desktop and the window-deocrations (title bar, close/minimise buttons etc.) and generally acts as the interface system on top of the software that actually sends a picture to the screen (X).

SMB (server message block) is the Windows file-sharing protocol. Samba is the open-source implementation of this protocol.

Press ctrl-alt-F1 and login as "root". (Your password wont be shown as yout type it)

Run the command "ls /dev/hd*"

That will give you a list of all the partitions on the computer. HDA is IDE primary master, HDB is IDE primary slave. HDC is secondary master and HDB is secondary slave. So - You need to know which partition you are trying to access (1 is the first partition, so hda1 is ide primary master partition 1).

Once you have worked that bit out, run "mkdir /mnt/ntfs" followed by "mount -t ntfs /dev/hdXY /mnt/ntfs" (where X and Y are the letter and number that you found for the partition). It should cause the filesystem to become "mounted" (available) at /mnt/ntfs. If not you will get an error which you can post here.


Posted by: jackdw Aug 30 2006, 01:35 PM

I'm really sorry about not coming back! I posted on another linux help forum and they sorted me out.
Thanks for your time anyway.

Powered by Invision Power Board (
© Invision Power Services (