Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Partition Problems

Posted by: igor Mar 10 2004, 08:22 PM

I'm running Mandrake 9.2 on an AMD K6-450 MoBo with a 1998 Award BIOS, have an Adaptec SCSI running four IBM disks, two 4GB, one 5GB, one 9GB. The two 4GB and the 9GB howl like banshees, so I decided to replace them with a WD 160GB IDE drive (WD1600JB-00EVA0). The system boots off of the 5GB SCSI, so I decided to make the IDE drive one huge volume (160GB, or whatever I coould get to format...) and mount it as /data0.

Hardware installation is just fine. BIOS recognizes it just fine. DiskDrake recognizes it just fine (in command line or in XTerm) (I'm running the KDE XWin desktop).

I format it for 152,625 MB, which is the largest DiskDrake will let me go, FSType is ext3 (type 83), mount point is /data0, I *do not* format it, click on the OK button, have it write to the fstab file, then exit DiskDrake and KDE desktop. Reboot. do a df. df reports that /dev/hda1 is only 7.1M big! I go back into DiskDrake to see what's going on, it says that /data0 in /dev/hda1 is formatted, mounted, and everything is peachy-keen. HUH?

Any ideas?

Steve Egan

Posted by: hughesjr Mar 10 2004, 09:00 PM

first thing ... no diskdrake...(just say NO to GUI laugh.gif )

open a terminal window and if you are not root, issue the command:

su - root

Now, unmount the drive:

umount /dev/hda1

Now let's load fdisk to partition the drive....

fdisk /dev/hda

You should be at a prompt that looks like this:

Command (m for help):

All commands given should be followed by the Enter Key
type m <--followed by Enter. I won't include the enter key any more)

This will give you a list of all the commands ... it should look similar to this:

Command action
  a   toggle a bootable flag
  b   edit bsd disklabel
  c   toggle the dos compatibility flag
  d   delete a partition
  l   list known partition types
  m   print this menu
  n   add a new partition
  o   create a new empty DOS partition table
  p   print the partition table
  q   quit without saving changes
  s   create a new empty Sun disklabel
  t   change a partition's system id
  u   change display/entry units
  v   verify the partition table
  w   write table to disk and exit
  x   extra functionality (experts only)

First thing we want to do is print the partition table ... so use the command:


next, we want to delete all the partitions on this drive ... it should only be one, using the command:


it will ask for a partition number ... use the number:


Now let's create a partition that uses all the disk space....use the command:


It will ask for the First Cylinder ... use the number 1
It will ask for the Last Cylinder ... the default will be the last cylinder ... take the default by pressing Enter

now let's print the partition table again, use p

if it looks right (hda1, large partition), let's save the table and exit with this command:


Now we are ready to create a file system on the disk:

use the command:

mke2fs -j /dev/hda1

Now let's make the file system not do automatic scans based on number of times mounted or after a period of time with this command:

tune2fs -c 0 -i 0 /dev/hda1

now, check the file /etc/fstab ... make sure the entry for /dev/hda1 has a filesystem type of ext3 ...

issue the command:

mount /dev/hda1

and do a:

df -h

Posted by: igor Mar 10 2004, 11:50 PM

I'm beginning to think I should stick to an abacus (see last week's strip in User Friendly)...
{yes, I'm as old as Sid *and* I've done the same stuff as he did...}

Been there, done all that. I thought that the GUI might have been screwed up, even though the GUI version of DiskDrake is actually calling /usr/sbin/diskdrake...

I even went so far as to boot the system with the LinuxCare 2.0 toolbox and using _that_ to format the disk after I tried formatting it from the command line - with the very same results. I'm beginning to suspect the BIOS's CHS table is crapping on the (software) drive parameters. In other words, the MoBo is just too old to support something as big as a 160 GB drive. I was hoping somebody else has encountered this problem and maybe has a workaround?? Speak up out there, y'all...


P.S. - I do all this as root. Is there any other login available?? ;P

Posted by: igor Mar 11 2004, 05:49 PM

Well, to all of you reading this post:

Looks like the 1998 Award BIOS just flat refuses to recognize 160G drives properly. Here's what I found:

Linux thinks the drive's CHS is: 19456 255 63
The Award BIOS thinks the CHS is: 16383 16 63
Western Digital says the CHS is: 16383 16 63

The BIOS says there's only 8.3 GB available on the drive. Apparently the BIOS is reading the params from the IDE controller correctly, but chokes on the information. If I go into the BIOS and set the drive params to what Linux wants, the machine freezes up. When I run fdisk, it sees the drive as a 160G. When I format it using either mkfs or mke2fs, it performs the format just fine. fsck or e2fsck barfs, reporting the superblock info is hosed. When I try to mount it, same story. No amount of coaxing/tweaking gets me anywhere, so I guess I'm stuck with putting the drive in my Windoze machine and ghosting its info over to the 160G drive. I'll use the Windoze's drive (80G) in the file server instead. Sigh.

I might see if I can get the BIOS flashed to a better version, but I will probably end up swapping the motherboard with something more modern. Such is life in the used MoBo world...


Posted by: hughesjr Mar 11 2004, 06:56 PM

I was going to recommend that (new BIOS) if fdisk didn't work biggrin.gif

Powered by Invision Power Board (
© Invision Power Services (