Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Nvidia Accelerated Driver Problems

Posted by: StevenMig Feb 29 2004, 10:03 PM

I installed the latest linux drivers, and when change the driver line in the XF86Config file to "nvidia" (from "nv") startx freezes. I have looked in the readme for the Nvidia drivers, and nothing there helps me. I have let the computer sit to see if it was just frozen, and it didn't work. I can hit ctrl-alt-del to restart though. The only way for me to use X windows system is to change the driver line to nv and when i do that no opengl progs work. I am running Red Hat 9 and I do have onboard that has cause problems on with Windows (and is detected at startup every once in awhile).

Posted by: veris2040 Mar 1 2004, 01:05 AM

I'm using Mandrake 9 and it took me a while to figure out nvidia linux instructions. Check to see if you have another file called XF86config-4 and try to change the settings there.

Posted by: Corey Mar 1 2004, 01:54 PM

After you run startx, a Ctrl+Alt+F1 to go back to your console and see if there are any error messages showing when X startups up. It may be missing something.

As well, when you edit your XF86Config-4 file, besure that under the modules section, that you comment out the "dri" and "GLinfo" lines (place a "#" at the begining of the line)

Posted by: hughesjr Mar 1 2004, 03:21 PM

The way the XF86Config files work is this...

If XF86Config-4 is present it is used ... otherwise XF86Config is used...

The GLcore thing is very important ... make sure it is remarked out.

In the file /var/log/XFree86.0.log you will have the errors logged why X couldn't start ... you can use the command:

cat /var/log/XFree86.0.log | grep "(EE)"

Posted by: StevenM Mar 1 2004, 09:38 PM

I have tried hitting ctrl-alt-F1 and it doesn't work. I will have to try it again though. Currently I am using the "nv" driver, and the log says it can't initialize the GLX extension (NVIDIA XFree86 driver not found). I don't have an XFree86Config-4 file.

Posted by: hughesjr Mar 2 2004, 09:29 PM

When you use the nv driver there is no GLX .... that is what makes the 3D stuff work!

use the command lspci and post any results related to video. Similar to this:

01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

post the Section "Device" section for your video card....here is mine

CODE
Section "Device"
       Identifier  "Videocard0"
       Driver      "nvidia"
       VendorName  "Videocard vendor"
       BoardName   "NVIDIA GeForce FX (generic)"
       BusID       "PCI:1:0:0"
EndSection


If you have more than 1 Section "Device" section, we may need to put the BusID in the XF86Config file for both cards...

Posted by: StevenM Mar 2 2004, 10:27 PM

CODE
Section "Device"
    Identifier  "Videocard0"
    Driver      "nv"
    VendorName  "nvidia"
    BoardName   "RIVA TNT2"
    VideoRam    16384
EndSection

I don't seem to have the lspci command, do you know any alternatives? (or maybe where to get it)
I had to manually set the VidRam to 16MB. Linux detected it as 4.

Posted by: hughesjr Mar 2 2004, 10:49 PM

lspci is provided by the package:

pciutils

Posted by: StevenM Mar 2 2004, 11:03 PM

00:00.0 Host bridge: Intel Corp. 82810 GMCH [Graphics Memory Controller Hub] (rev 03)

00:01.0 VGA compatible controller: Intel Corp. 82810 CGC [Chipset Graphics Controller] (rev 03)

01:0b.0 VGA compatible controller: nVidia Corporation NV6 [Vanta/Vanta LT] (rev 15)

Posted by: hughesjr Mar 3 2004, 06:15 AM

try setting your BusID like this:

CODE
Section "Device"
    Identifier  "Videocard0"
    Driver      "nv"
    VendorName  "nvidia"
    BoardName   "RIVA TNT2"
    VideoRam    16384
    BusID       "PCI:1:11:0"
EndSection


If that works, try shifting back to nvidia for the driver...

Posted by: StevenMig Mar 3 2004, 05:16 PM

Thank you very much!! It works now.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)