Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ "no Such Device"

Posted by: cguillet Feb 24 2004, 09:27 AM

What does the error message "No such device" mean?

I configured a Lucent winmodem using the rpm package ltmodem. Configuration appeared to be successful. Linux put the modem on ttyLT0.

When I try to access the modem (through KDE or the bash shell), I get an error message that say "No such device."

The modem file, /dev/modem, also returns "No such device." (I assume it is linked to ttyLT0).

There IS a device named ttyLT0 in the /dev directory. It can be accessed with the "ls" command, but efforts to "display" the contents of the device with "cat" also return "No such device."
Any suggestions? SuSE support got me this far and won't help anymore because they say it's a hardware issue.
thanks in advance

Posted by: cguillet Feb 25 2004, 09:45 PM

I've run this to ground and found it to be a problem with the ltmodem rpm package from SuSE. Linux loads ltmodem, then unloads it (citing a licensing problem), then switches to ltserial (which is itself a part of the ltmodem rpm package). Ltserial returns an error message. Then the process shuts down, resulting in a "No such device" error when the modem is thereafter triggered.

I tried the latest update of the rpm package (I think it's 8.26a-179.patch.rpm)--no luck.

Posted by: linuxwolf069 Mar 6 2004, 04:40 PM

there is a way to check the modem to see if it is working in linux without requiring the drivers to be loaded..


I wrote a FAQ about this for another forum... It can be found at:

http://www.phlak.org/modules/xoopsfaq/index.php?cat_id=2#q12

give that a shot.

Posted by: reductionist Mar 7 2004, 01:08 PM

OK, best thing is to download the ltmodem source files (don't panic, this is really straightforward!). Once that's done maybe login as root. Extract the gz file (right-click in GNOME or KDE and choose "extract to.." option). This will create a directory called ltmodemxxxxx (xxxxx = version number). Open a terminal. Move into this directory ( cd ltmodemxxxxx ). Look at the readme file. Now, do "./build_module" (for pre-2.6 kernels) and accept all the <press enter to continue> prompts (about 20 of them, if memory serves...).

Anyway, it will tell you if it encounters any errors and if it all is well just do what the program says and you will, all things being equal, have a working winmodem!.

I found it worked first time and for subsequent kernel compiles - just repeat the process. I have since moved to 2.6.3 and the new ltmodem driver (beta) works just as well. It is a godsend - those guys really know what they're doing.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)