Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Suse Linux 9.0

Posted by: Grr8xTc Feb 18 2004, 05:59 PM

hi everyone, i am new to this forum and new to linux. i just purchased Suse Linux 9.0 and want to update the graphics drivers for my geforce fx 5900 ultra, but dont know how. the file i downloaded from Nvidia is a .run file. can someone tell me how to do this, or give me a link where i can read up on how to do this?

thanks in advance biggrin.gif

Posted by: hughesjr Feb 18 2004, 06:37 PM

If you boot to a GUI display, login

Use this (print it or save it to your hard drive before you start):

ftp://ftp.suse.com/pub/suse/i386/supplementary/X/XFree86/nvidia-installer-HOWTO

... open a terminal window ... if you are not root, use the command:

su - root

as root, issue the command:

init 3

If you see the SUSE Graphical login bar at 100%, press F2 ... you should now see a login prompt...

login as root...

The only thing I would change is this:

first from the terminal, do this:

chmod 755 NVIDIA-Linux-x86-1.0-5336-pkg1.run

in the command to install the software, use this command (all on one line):

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run

instead of the one recommend by suse:
sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

(IGNORE_CC_MISMATCH will compile if the gcc version used to compile the kernel is different than the gcc version on your linux install ... which is the case most of the time)

after install is complete, do the sax2 command from the above link...setup your monitor/card

reboot

Posted by: Grr8xTc Feb 19 2004, 07:34 AM

big HUGH thanks to you for your help. when my friend told me to find a forum and post my problem i originally thought he was nuts. guess i owe him a big apology. again THANK YOU so much.

Posted by: Grr8xTc Feb 19 2004, 04:34 PM

i came home and tried to install the drivers. i typed in everything that was posted but i didnt see anything happen. maybe you dont, i dont know. i do not understand the "do the sax2 command from the above link...setup your monitor/card" portion. sorry to be a big pain in the butt. i know how to get to sax2 with the GUI but that is about it.

Posted by: hughesjr Feb 20 2004, 09:10 AM

OK ..

when you did init3, did you get into the console as root?

When you ran:

IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run

Did you get the installer and have it compile your Nvidia driver? (it will bring up a selection program for you to read the license, etc....you must be inthe directory where the file you downloaded (NVIDIA-Linux-x86-1.0-5336-pkg1.run) is when you issue the command) .... you might need to make the file executable with the command:

chmod 755 NVIDIA-Linux-x86-1.0-5336-pkg1.run

before you do the IGNORE_CC_MISMATCH=YES ./NVIDIA-Linux-x86-1.0-5336-pkg1.run command
-----------------------------------------------------------------------------------------
What I meant by the sax 2 thing is to read the page:

ftp://mirror.mcs.anl.gov/pub/suse/i386/supplementary/X/XFree86/nvidia-installer-HOWTO

in section I for Suse 9.0 and do what it says ... here is the applicable secion:

QUOTE
I. SuSE Linux 9.0
-----------------

1) Kernel sources must be installed and configured. Usually this means
installing the 'kernel-source' package with YaST2. Update it - if not
already done - via YaST2 Online Update (YOU).

2) Use the nvidia installer for 1.0-5336.

sh NVIDIA-Linux-x86-1.0-5336-pkg1.run

3) Configure XFree86 with

sax2 -m 0=nvidia (0 is a digit, not a letter!)

NOTE: There is no need to try to enable 3D support. It's already
      enabled, when the nvidia driver is running. Ignore the
      misleading error message, that 3D support can't be enabled.
      This problem will be fixed with SuSE > 9.0 and is related to the
      latest nvidia driver release.


So ... you have to have the package kernel-source installed ...
do the command:

rpm -q kernel-source

the output from my suse install is this:

kernel-source-2.4.21-192

If you don't have kernel-source installed, you have to install it via YAST. (The YAST - Software ... Install/Remove Software section)

Once you have kernel-source installed, installed kernel and the kernel source versions must match ....

do the command:

uname -r

My output:
2.4.21-192-default

and the command:

rpm -q kernel-source

My output:
kernel-source-2.4.21-192

If the versions don't match ... use the On-Line update section of YAST - Software after all updates are applied, check the versions again as above ... keep doing it til they match.

Once they match ... do the installer commands to install drivers (per the instructions above), then run the command:

sax2 -m 0=nvidia

and setup your desktop and monitor.....

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)