Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Modem Trouble

Posted by: darsmit Jan 30 2004, 12:25 PM

I recently had SuSE Linux 8.1 installed on a new eMachine, partitioned to include Windows XP on part of the hard drive. Linux did not autodetect the modem, so I tried to install it, following the instructions. But when I enter a URL on the Konqueror browser, it does not connect. I get an error message about not knowing/recognizing the host (or words to that effect). Is the problem in my installation or in the eMachine modem itself?

Posted by: Corey Feb 2 2004, 11:16 AM

First off, i take it your setting up dial-up access right?

If your modem was, indeed, set up after following the instructions, you need to setup a connection so your computer dials-up to your ISP, negotiates the connection with a username and password, and then establishes a PPP connection. In KDE, you can use the utilitiy "Kppp" which is normally located in the Networking menu. With this program, you can setup the connect with your ISP, enter in your username and password, and dial-up. Kppp does include an option to "Dial on demand" which means when you go to try and access something on the internet while you're not connection, it'll prompt you to dial-up. The bottom line is, you need to configure kppp first before you can do anything.


To test and make sure your modem worked okay, you can use Wvdial or even minicom.

Posted by: hughesjr Feb 2 2004, 10:36 PM

thanks corey ... I'm afraid I have no idea how to use a modem in Linux .... I have always used an ethernet card for connecting....

So I'm not much help with any modem questions unless they are compile or driver problems laugh.gif

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)