Printable Version of Topic

Click here to view this topic in its original format

Linuxhelp _ Hardware Support _ Soundblaster Awe32 Isa Pnp

Posted by: SlackMAN Jan 21 2004, 11:27 PM

I just installed Slackware 9.1 on my box (kernel 2.4.22).

Everything is working fine, except I have no sound.
I've tried going through the Plug-and-Play-HOWTO, and I haven't had any luck.
I'm using an old SoundBlaster AWE32 card (ISA PNP (io=0x220 irq=5 dma=3 dma16=6 mpu_io=0x300)).

I've tried enabling and disabling plug-and-play in my BIOS, I've tried with and without isapnp, I even tried to use ALSA to configure the card. Nothing seems to work. I get insmod errors when the modules try to load, even with the correct IRQ/DMA/IO settings.

I'm at my wit's end, I've never had this much trouble with Linux before and I've been running it since 1993.

Any suggestions will be welcome, except maybe "try a different sound card" tongue.gif !

Thanks in advance,

SlackMAN

Posted by: hughesjr Jan 23 2004, 06:41 AM

In the 2.4.22 kernel, there are different options that can be compiled in concerning ISAPNP and soundblaster cards.

Can you ... have you ever compiled your own kernel?

Just a note:
ISA cards are very hard to setup ... PCI cards are much easier

Posted by: SlackMAN Jan 25 2004, 12:24 PM

Yes, I'm very familiar with recompiling my kernel. I don't know how this would help, though.

Let me know what you had in mind...

Sincerely,

SlackMAN

Posted by: hughesjr Jan 27 2004, 07:43 AM

I just looked at my slack 2.4.23 kernel (I don't have 2.4.22 anymore).

I didn't see anything out of the ordinary, there is a selection under plug and play devices for ISAPNP and a modules in Sound Devices for SB 16/32/64 ...

In my stock kernel, both of those are already selected as Modules.
----------
I was thinking of the 2.6.1 kernel where the ISAPNP was not compiled in, sorry.
---------
Try modprobe isa-pnp followed by modprobe sb (at least on 2.4.23 that works with an AWE-64 that I just tried).

Posted by: SlackMAN Jan 27 2004, 05:26 PM

When the module tries to load, I get "device or resource busy", but I don't see any conflicts with any other hardware.

I don't know what else to do.

Suggestions?

SlackMAN

Posted by: Corey Feb 2 2004, 11:19 AM

Slightly off-topic, and may not be any help, but, is it possible to instal Redhat's "sndconfig" utility? I know I've used it in Debian, so i'm sure it's possible to "Alien" it to slackware. I find that utility quite useful and painless for setting up ISA soundcards.

As well, out of curiostiy, when you run "isapnp /etc/isapnp.conf", does it say it found the sound card?

Posted by: SlackMAN Feb 7 2004, 10:35 PM

When I run isapnp it says it sees everything just fine (i.e. everything comes up "OK").

I'll look into the sndconfig thing, but I doubt it would run on Slack. I dislike Red Hat because of some things that it has done to me in the past.

Thank you for your input, though.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)